Popravak: .NET Framework 4.7 nije podržan u ovom operacijskom sustavu

Savjetuju: Kliknite Ovdje Za Škripac Windows Pogreške I Performanse Optimizirati Sustav

.Net Framework je programska infrastruktura koju je uveo Microsoft. Trebat će vam .Net Framework za pokretanje različitih različitih aplikacija i usluga. Većina aplikacija koje zahtijevaju. Net Framework također dolazi u paketu s instalacijskim datotekama. Dakle, automatski će se instalirati na vaš sustav prilikom instaliranja aplikacije. No, možda ćete vidjeti pogrešku ".NET Framework 4.7 nije podržan u ovom operacijskom sustavu" prilikom instaliranja aplikacije. Ova će vam pogreška onemogućiti uspješnu instalaciju aplikacije. Ovu će pogrešku možda vidjeti prilikom pokušaja instaliranja .Net Framework kao samostalne aplikacije / usluge.

Razlog zašto se ova pogreška događa je isti kao što je spomenuto u poruci o pogrešci. Iako je .Net Framework podržan u sustavu Windows 10, ali nije kompatibilan sa svim verzijama sustava Windows 10. Dakle, ako vidite ovu poruku, onda je najvjerojatniji uzrok ove pogreške taj da koristite Windows 10 verziju koja nije kompatibilan s .Net Framework.

1. metoda: Ažurirajte Windows 10

Jedino rješenje za ovaj problem je jednostavno ažuriranje sustava Windows 10. Savjetuje se provjera Windows Ažuriranja čak i ako ste na najnovijoj verziji sustava Windows 10. Budući da je problem uzrokovan nekompatibilnim operativnim sustavom, instalirajte sve dostupne Windows 10 ažuriranja će najvjerojatnije riješiti problem. Također možete provjeriti točnu verziju sustava Windows 10 i verziju koju zahtijeva .Net Framework slijedeći korake dane u nastavku.

  1. Držite tipku Windows i pritisnite R
  2. Upišite winver i pritisnite Enter

  1. Vaša verzija treba biti spomenuta u novootvorenom prozoru. Broj nakon Verzije (u drugom retku) vaš je broj verzije. Broj bi trebao biti 1507 ili 1709. Prve dvije znamenke su godina, a druga 2 je mjesec. Dakle, ako imate verziju 1709, to znači da pokrećete verziju objavljenu u rujnu 2017

  1. Sada morate biti sigurni da imate verziju sustava Windows 10 koja je kompatibilna s .Net Framework. Kliknite ovdje i kliknite na Zahtjevi sustava

Ako pogledate odjeljak Podržani operativni sustav, piše da se ažurira Windows 10 Anniversary Update i Windows 10 Creators ažuriraju . Budući da mnogo ljudi nije upoznato s brojevima verzija koji su povezani s obrascima Obljetnice i Kreatori, spomenuli smo ih u nastavku

  • Novembar (1511)
  • Obljetničko ažuriranje (14393)
  • Ažuriranje za kreativce (1703)
  • Ažuriraj kreativce za pad (1709)
  • Proljetno ažuriranje kreativaca (1803)

Kao što vidite, Anniversary Update ima verziju 14393, a Creators Update ima verziju 1703. Dakle, ako imate verziju nižu od 14393, tada nećete moći instalirati .Net Framework 4.7 na Windows 10. Sada jednostavno ažurirajte Windows i provjerite da imate najnoviju verziju sustava Windows 10 i pokušajte ponovo.

Zanimljivi Članci